← Prev in month ← Prev in thread
Next in thread → Next in month →

PR Comment: Language Spec: IP Subnet Target

From
Mr. David Kemp <>
Date
2018-10-26T17:57:55+00:00
ID
Thread
PR Comment: Language Spec: IP Subnet Target
Section 3.3.1.2 "Target", Line 591 defines a list of target types.  Target 11, ip_addr, is a host IP address, a 32 bit IPv4 (RFC 791) or 128 bit IPv6 (RFC 8200) address.

Many use cases involving network routing/filtering require an IP subnet address consisting of a network part and a host part.

To support these use cases, add a new "ip_subnet" target consisting of a 32 bit or 128 bit IP address and an integer subnet prefix.  The value of the subnet prefix shall be as shown in the CIDR column of RFC 1878 for IPv4 and the Prefix Length value of RFC 4861 section 4.6.2 as updated by RFC 5942 for IPv6.
← Prev in month ← Prev in thread
Next in thread → Next in month →