Next in thread →
Next in month →
RE: [emergency] Problem posting CAP 1.1 messages
Patti wrote: > the namespace that they reference is a url which does not > resolve: http://www.incident.com/cap/1.1 The namespace specification explicitly states that "It is not a goal that [the namespace name] be directly usable for retrieval of a schema (if any exists)." See: http://www.w3.org/TR/REC-xml-names/ (read the second [definition] in section 2) There is no requirement that a URI which is a namespace name can actually be dereferenced ("resolved"). A namespace is not identified by an URL or URN (which one would expect to be able to dereference) it is identified by a URI (which is merely an identifier). A URI is in a form that allows it to be dereferenced (like an URL) however; it is NOT a requirement that dereferencing be possible. If your code breaks because the URI cannot be dereferenced, it is not a failing of the CAP or Namespaces specifications. It is a failing of your code. bob wyman -----Original Message----- From: [mailto:] Sent: Wednesday, February 16, 2005 6:19 PM To: Cc: Subject: [emergency] Problem posting CAP 1.1 messages One of our developers, Brad Cupit, is attempting to post CAP 1.1 messages, but he is having problems. I sent him Kon's alternate schema (posted 1/12/2005), but he still can't get it to work. I'm hoping someone can point him in the right direction. Below is the latest message from him: "I looked at the schema files that you sent and the namespace that they reference is a url which does not resolve: http://www.incident.com/cap/1.1 I tried running puff without any namespace at all, and it defaulted to the 1.0 version. [Maybe] Im pointing to a 1.0 DMIS server instead of a 1.1 version. Do you know the url for the 1.1 DMIS server?" All suggestions/advice appreciated... Patti
Next in thread →
Next in month →